A typescript question need help!

i have create a theia base browser IDE but when i open an typescript eitor there a probems about override keyword , how i can fix the probelms.

problem info is Member ‘override’ implicitly has an ‘any’ type

My IDE is base on theia 1.25,plugins about typescript is vscode-builtin-typescript 1.53.2 and vscode-builtin-typescript-language-features 1.53.2

@aligu thank you for the discussion and welcome the community.

The version 1.53.2 of typescript-language-features does not support the override keyword or the noImplicitOverride flag, please see the following issue https://github.com/eclipse-theia/theia/issues/10819.

In order to use a newer version of the builtin, some additional vscode api need to be implemented which are referenced in the above issue.

1 Like

thank you for your answer, its a great help for me.