An error while debug a java project

Hi,i could debug my java project before,but while i create an new theia project as the guid,and use it to debugger the java project,it show an error msg:

Failed to launch debuggee in terminal. Reason: terminal “0” does not exist

node 16.15.1
java 17

Is there some advice on how could solve it?

@passion123 thanks for the discussion, I’m not sure which version of vscode-java-debug you are using but it seems to be an issue related to the plugin itself.

For example a similar issue mentions playing around with the java.debug.settings.console preference.

I have tried to find the reason as below:
I run two different version theias on the same windows pc with the vscode-java-debug version of 0.26.0 and the 0.45.0, the theia 1.27.0 debugs well. But the version 1.31.0 shows the error “Failed to launch debuggee in terminal. Reason: terminal “1397319980” does not exist”



Seems it is a new error.Do u have any advice ?

Do u have any advice ?

@passion123 I don’t have much more advice besides taking a look if it works with the same setup in vscode, and taking a look at the extension’s faq or asking directly there.

Locally I’ve done a sanity check with a simple launch configuration (Launch Current File) and it works as intended. It might be that the debuggee you chose in your config is incorrect but I don’t think I can help further unfortunately.

thx for ur tips and tricks. i’ll leave a msg on the extension faq.

@vince-fugnitto
Hi,sorry for disturbing u again.
Here is the logs while the error “terminal “1397319980” does not exist” showing.
Have u ever seen it or some tips on solving it?