Appimage and sandbox issues with vscode extensions when building Theia Blueprint based apps

Hi, I’m trying to continue work on Beancolage, and one of the issues I’m trying to fix first is a discrepancy in how a vscode-extension I bundled (vscode-beancount) works when launching the AppImage from a terminal, but doesn’t work when clicking the same AppImage file to launch it (on Gnome Files on Linux, nor via desktop entry).

To be more specific, the vscode-beancount extension makes a call to child_process.spawn ( vscode-beancount/utils.ts at e3e0593b1656219c58177fc03905eb849607344d · Lencerf/vscode-beancount · GitHub ) with a python script in order to get information to report as errors & warnings for a given file. The screenshot comparison gives a better idea of what happens.

What I’ve tried so far:

  • The desktop entry I use for Beancolage was generated by AppImaged, and has Exec=/home/me/Applications/appimaged-730-x86_64.AppImage wrap "/home/me/Applications/Beancolage.AppImage" --no-sandbox %U as it’s exec line. I’ve tried running this line directly from the terminal and the extension still works fine.
  • Ignoring the desktop entry, the issue also happens when clicking on the AppImage file directly from Gnome Files.
  • I’ve tried to see if an error message gets generated both via the frontend debugger (including checking verbose) and in the OS logs. Supposedly the vscode extension would relay child.on('error', (e) => logger('error: ' + e)); , but so far I don’t see any error messages come up.

Any ideas what could be happening or how to approach further debugging?

Thanks,

Vivek

Hey @vivekgani,

given that the error logs from the vscode extension are not printed, I would assume that your extension isn’t started. I am very much confused though, since there should be virtually no difference between starting Theia from the terminal compared to starting it via clicking on the AppImage file. Can you somehow get to the backend logs and see whether your extension is actually deployed by the backend?