Are there any caveats to applying 1.39.0 Release?

When applying the 1.39.0 release

The browser’s console displays the

“Failed to load resource: the server responded with a status of 404 (Not Found)”

You’ll see an error like the one above.

I ask because there is nothing in the migration documentation about version 1.39.0.

Hey @VICTUS,

usually, the migration guide is updated by adopters that found migration issues during their upgrade. The framework developers usually document their breaking changes in the changelog. It might be that the move from lib to lib/frontend for frontend files has broke some build process you have set up. However, the default express server should pick up these files as expected.

In my case, the current 1.38.0 version works fine, but when I run it,

After updating to 1.39.0, when I run it, the tool doesn’t run and the browser displays the

The output is an image like the one above.

Does the above situation give you any clues?

I’ve gathered as such from your initial post in this thread. Again, some resources have changed position (from lib to lib/frontend). Depending on your setup, your express app might not resolve the index.html as expected.

1 Like

I’m currently testing with browser, so lib/frontend is being created normally in the browser-app folder.

However, what is different from 1.38.0 is that lib, src-gen, webpack, etc are being created in the root folder.

My directory structure is running based on the blueprint.

If the express app is the problem, is there something wrong with the backend related extension I created?

Resolved.
One of the methods I tried seems to be the solution, but I don’t know which one exactly worked.

  1. change applications/browser-app foldername → browser and change some root package.json script.

  2. in frontend extensions, change @inject from public to protected.

  3. node.js version 16.15.1 → 18.12.0.