Build issues (was Node version?)

I’m trying to build Theia following

I use Node v16.13.0 . Prerequisites from the link above says "Node.js >= 12.14.1"

Still I get:

error dugite-extra@0.1.14: The engine “node” is incompatible with this module. Expected version “>=10.11.0 <13”. Got “16.13.0”

What to do?


PS. I know I could downgrade Node but I’m looking for a more proactive solution. DS

@patna thank you for the discussion, if you happen to use the git extension and not the builtin git plugin you might see the dugite error. If so you can perform the following instead yarn --ignore-engines.

We are in the process of enabling support for Node 16 but dugite-extra has this range triggering the error. It would be fine to keep using Node 12 for some time still, or do as Vincent suggested and running yarn --ignore-engines to get past the error you reported.

There’s actually two PRs to have dugite-extra work when used in Node 14/16:

Note that the current supported version of Electron embeds Node 12 still.

Ok, thanks. Got a bit further. Now I get “pkg-config: not found”

After installing that I get “Package x11 was not found in the pkg-config search path”

Is X11 necessary for the generic build/yarn step?


@patna pgk-config is one of the prerequisites, did you install it?

Now I did, sorry, missed that,

Still problem with X11

Note to self: Read and execute all prerequisites before asking stupid questions.