Error: The language client requires VS Code version ^1.41.0 but received version 1.6.0

Hi I am trying to use https://open-vsx.org/extension/golang/Go/0.17.2 in ubuntu20.04 but getting error ERROR [hosted-plugin: 69123] Promise rejection not handled in one second: Error: The language client requires VS Code version ^1.41.0 but received version 1.6.0 , reason: Error: The language client requires VS Code version ^1.41.0 but received version 1.6.0 root ERROR [hosted-plugin: 69123] With stack trace: Error: The language client requires VS Code version ^1.41.0 but received version 1.6.0 Any idea what is going wrong here

@sumeshkanayi a similar question was recently raised and answered here: https://github.com/eclipse-theia/theia/discussions/8601.

The app having VSCODE_API_VERSION of 1.6.0 would have to be based on a very old version of the Theia plugin system and framework, no?