Horizontal scroll bar

Viewing very large strings of text results in line breaking or wrapping…

How can I just increase the amount of horizontal scrolling?

[original thread by AssertLife]

You can control it using the preference editor.wordWrapColumn to choose the number of columns you’d like visible before wrapping

And using the preference “editor.wordWrap”: “wordWrapColumn”

[AssertLife]

Thank you for your reply!
Once I save the file, close it, and view it again the wrapping stays the same…
There is no horizontal scrolling at all

@assertlife you’ve updated both preferences and experience that behavior?

[AssertLife]

@vince-fugnitto Yep… https://i.imgur.com/pjUD4sZ.png https://i.imgur.com/x6Pumkb.png

[AssertLife]

Oh hold on… I need to change wordwrap

In my case I have it set to 20 so you can see my lines wrap after 20 char

[AssertLife]

everything looks normal at the moment, how does your file look?

[AssertLife]

still the same… but I will try a different string or file and report back in a minute

[AssertLife]

Works on new file… there’s no wrapping

[AssertLife]

Perhaps Theia escapes characters and goes one line down?

[AssertLife]

now I deleted the base64 string and replaced with random string… it works

[AssertLife]

I think there’s a maximum threshold…

[AssertLife]

I’m almost sure

[AssertLife]

when the threshold is met, the preferences revert back to wrapping, regardless of the amount you specified at wordWrapColumn

[AssertLife]

It happens with any string

[AssertLife]

@vince-fugnitto If you can confirm… set wordWrapColumn to 100000 for example and write 30,000 length string, it should wrap