Is it possible to use a newer version of FontAwesome?

I’d like to use some of the newer FontAwesome icons. Is it possible to build theia with FontAwesome 5?

@bendavis since the update from FontAwesome 4 to 5 includes breaking changes (ex: icon names), and other updates the only practical way I see to perform the update and migration would be to upstream your changes to the framework. There are some guides on how to do so:

Please note that this will be a breaking change for the framework since it is possible that downstream application refer to old icon names which have been updated and will fail to load (unless a shim is used).

Please feel free to provide an upstream pull-request if you’re intererested in the feature.