Jupyter server crashed. Unable to connect. Error code from jupyter: 1

Hello, anyone have any ideas why (or how to troubleshoot) jupyter crashing? If I run the theia-python image locally it works ok (except for the same 404 errors related to the editor_worker.js). On GCE behind a proxy, with the THEIA_WEBVIEW_EXTERNAL_ENDPOINT={{hostname}}, I cant seem to get a single cell to run. I’ve tried installing and reinstalling jupyter in the terminal.

any ideas?

@shortwavedave I believe webviews require a secure connection (ssl) to start the webworkers.
Some more information can be seen in the following issue: https://github.com/theia-ide/theia-apps/issues/423#issuecomment-706900991

Which version of the vscode-python is this? I thought we were missing a bunch of API’s to make jupyter notebooks work.

Thanks for the reply @vince-fugnitto! This site happens to be secure, but that is a line to consider. I wonder if there is a header or something not being passed to the theia container, since it lives behind a reverse proxy in this case. Maybe gitpod has some configuration that I should consider…

Hi @tsmaeder - the version in my package.json is:

“vscode-python”: “https://github.com/microsoft/vscode-python/releases/download/2020.9.114305/ms-python-release.vsix”,

Since it works locally, I thought it would be ok behind a proxy