No way to execute an extension following the guide

Hello all,
I tried to test the extension generation following the guide in the Theia site (authoring extensions) but after running “yarn start” within the “browser-app”, the resulting IDE does not show the menu entries, and shortcut keys don’t work either.

Can someone help out?

Hi @davidg.kairos, thank you for your question.

Does the application show no menu entries at all? Or just not the ones contributed but your extension?

Perhaps you need to rebuild your application. Running yarn in the root directory usually does the job.

Hi, thanks for your response.
The application does not show any menu entries on the main menu bar. Running yarn does not fix it.

My extension is simply the “Hello world” sample extension, created with the generator following the guide, nothing more yet. I try to get to grips with extension creation.

It looks like there is something missing or that some configuration gets broken along the way

I verified it only happens on the browser version, the menu bar div is empty (no content).

Maybe it’s relevant to say that I am running this on a mac, BigSur, although it is Intel-based (no M1)

Are there any error messages in the browser log? Which browser, by the way?

No errors in console, using Chrome 91.0.4472.164.
I see others are having similar issues: Invisible Toolbar Menus

Verified: no errors on server console nor on Chrome’s dev console. Only two warnings regarding slow performance:

I did a downgrade of @theia dependencies to v1.16.0 and now it works. There must be a conflict in the latest release somewhere. Unfortunately, no error appears anywhere…

As explained in Invisible Toolbar Menus, the temporary (and quick!) workaround are either:

  • reset the workbench layout through the command,
  • or modify the menubar visibility in the preferences pane (just set one value)

Thanks to all of you who took a look into this :smiley:

@davidg.kairos, we identified the issue and a fix is on its way (see #10034). Though I’m not quite sure whether we’ll do a bugfix release for this. So I assume it will be included in 1.18.

1 Like

We did!

The menus randomly disappearing is a bad enough bug that we thought better to release a patch just for it.

2 Likes

This is great guys, thank you very much!