Plugins - Can't find 'Hosted Mode' / Hosted: Plugin - Option in (F1) Menu

Hey, I’m trying to get a plugin to build work, I’ve ran the yeoman generator command and it successfully creates the new “subproject?” however, I cant seem to step into this ‘subproject’ by following the instructions at.

https://www.theia-ide.org/doc/authoring_plugins

Next steps?

[original thread by Vince Lynch]

[LouBen3010]

Please check your package.json - is the dependency for @theia/plugin-ext set there? In my case this was missing when using yeoman.

[Vince Lynch]

Hey @louben3010 I added @theia/plugin-ext to my package.json and still cant see hosted mode.

[Vince Lynch]

so i followed this tutorial -> https://www.theia-ide.org/doc/Composing_Applications.html and then inside that folder that runs the theia browser ide using Yarn, yarn theia start --hostname 0.0.0.0 --port 4002, I then use the plugin CLI tool which creates a folder inside with the new plugin name, in this case ‘plugin1’

[Vince Lynch]

But none of the features of plugin1 appear in the theia-ide browser app I’m running using that start command.

@vincelynch Could you push your extension somewhere to try out?

[Vince Lynch]

Hi, I found the solution to this last night. The reason I could not find any options relating to plugins was I was using the instructions on https://www.theia-ide.org/doc/Composing_Applications.html rather than the instructions on https://github.com/theia-ide/theia/blob/master/doc/Developing.md#quick-start

Hello, guys. Don’t understand how to get the hosted mode.
I created plugin by yo @theia/generator-plugin -> added “@theia/plugin-ext”: “latest” to package.json -> opened the plugin folder in Theia -> build with yarn in Theia terminal. And there are no Hosted commands in Find Command…
I tried to download the builded electron version of Theia, tried to build by my own. Tell me, what am I doing wrong?

@Berlizov the hosted plugin command is contributed by the @theia/plugin-dev extension.
Make sure that it is included in your application:

Thanks for the tip. I downloaded everything from the git and made a full build. The commands have appeared.
But on windows machine I got “Activating extension ‘pluginName’ failed: Failed to execute ‘importScripts’ on ‘WorkerGlobalScope’: The script at ‘http://localhost:3030/hostedPlugin/theia_ pluginName/dist/pluginName-frontend.js’ failed to load.” error when I try to run the hello world example in hosted mode.
And on Mac it’s even worse - “Parsing error: “parserOptions.project” has been set for @typescript-eslint/parser. The file does not match your project config: pl/pl/src/pl-frontend.ts. The file must be included in at least one of the projects provided.” It feels like the linter is working several folders higher than it should.