Plugins

Trying to use the yeoman generator to create a plugin, whether it be front end or back they appear broken, errors with ‘Thenable’ and invalid reference directives. I’m interested in the language server example and this reports more errors due to ‘languageServer’ not being a property on theia.

I created a plugin months ago which works and build fine.

Any help appreciated.

language smartness can be contributed only via vscode extension

OK thanks, I guess the yeoman projects that are generated are out of date then?

maybe, I am not sure which project, is there some language server termplate? cc @vince-fugnitto

I try to maintain our theia extension generator but I haven’t touched our theia plugin generator which is the example refered to in the discussion. If there is an issue with the template, you can open an issue here @StevieD666.