Theia IDE Terminal not opening


I do have a problem with theia web 1.34.2 and 1.34.3. When I try to open a terminal (Terminal → New Terminal) absolutely nothing happens. The context menu closes, but the terminal does not open, and I do also not get any errors in the JavaScript console in the Browser nor do I see any errors in the theia logs (started with --log-level=debug). I’m not sure how to troubleshoot further without any errors. Things I tried:

  • setting SELinux to permissive (does not resolve the issue and I also do not see any SELinux violations in the audit.log)
  • Tried differen Browsers (Firefox 110.0 (64-bit) and Chromium 111.0.5563.64 (Official Build) Fedora Project (64-bit)) → Problem exists with both browsers
  • disabling all the plugins (does not resolve the issue)
  • Downgrade to version 1.34.1 (does “resolve” the issue)

Does anyone have similar issues or maybe an idea on how to troubleshoot this further?

Many thanks

@rekup thank you for the discussion, are you trying to open a terminal without a workspace present? If so you might be encountering a bug that is fixed with terminal: fix 'new terminal' handling by vince-fugnitto · Pull Request #12322 · eclipse-theia/theia · GitHub.

Hi @vince-fugnitto
That was it! Thank you very much for the hint. After opening a workspace the terminal works as expected.

Thanks again

1 Like