Unable to build theia yarn build fails

d:\CeliumDevices\theia-hello-world-extension\my-app\theia>yarn
yarn install v1.22.19
$ node-gyp install
node:internal/modules/cjs/loader:988
throw err;
^

Error: Cannot find module ‘d:\CeliumDevices\theia-hello-world-extension\my-app\theia\node_modules\node-gyp\bin\node-gyp.js’
at Function.Module._resolveFilename (node:internal/modules/cjs/loader:985:15)
at Function.Module._load (node:internal/modules/cjs/loader:833:27)
at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)
at node:internal/main/run_main_module:22:47 {
code: ‘MODULE_NOT_FOUND’,
$ yarn -s compile && yarn -s build:examples
Compiling TypeScript sources…
node:internal/modules/cjs/loader:988
throw err;
^

Error: Cannot find module ‘d:\CeliumDevices\theia-hello-world-extension\my-app\theia\node_modules\ts-clean\dist\bin.js’
at Function.Module._resolveFilename (node:internal/modules/cjs/loader:985:15)
at Function.Module._load (node:internal/modules/cjs/loader:833:27)
at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)
at node:internal/main/run_main_module:22:47 {
code: ‘MODULE_NOT_FOUND’,
requireStack: []
}
error Command failed with exit code 1.
info Visit yarn run | Yarn for documentation about this command.

I have installed node-gyp v9.3.0 and all the prerequisites from the example application document.

@AmrutaDeshpande21 thank you for the question but I believe you already opened 'MODULE_NOT_FOUND' · Discussion #11791 · eclipse-theia/theia · GitHub? There is no need to open the question in both forums.