Update vscode default api version?

Can the default api version of vscode be updated to the latest (1.37.1) ?
Currently it’s configured in theia to be 1.33.1 and missing some new apis.


Are there any restriction doing so?

[original thread by DoroNahari]

@dna yes, please file a PR

there is also env variable to work it around

btw what is the motivation?

you can also specify vscode api version on start, see https://github.com/theia-ide/theia/pull/4774#issue-266298249

[DoroNahari]

There is new file system api since 1.36 https://code.visualstudio.com/updates/v1_36#_vscodeworkspacefs

ok, i thought you want to use some extension which require 1.37.1? anyway please do a PR we are ok to be aligned with latest version

[DoroNahari]

Ok, I guess some adjustments need to be made for this new api to work?

@dna there are usually 2 issues, an extension cannot start because version is not supported yet or api is not implemented. Just bumping up a version will solve the first one. In order to implement a new API, we need a separate PR.