View Call Hierarchy not working

Hi everyone,

I’ve been trying to use the Call Hierarchy feature with typescript but It doesn’t work.
I deploy IDE on a docker container and here is my package.json.

{
  "name": "intregrated-development-environment-frontend",
  "version": "0.0.0_beta",
  "private": true,
  "theia": {
    "frontend": {
      "config": {
        "applicationName": "Theia JavaScript/TypeScript Example",
        "preferences": {
          "files.enableTrash": false
        }
      }
    }
  },
  "dependencies": {
      "@theia/editor-preview": "latest",
      "@theia/getting-started": "latest",
      "@theia/markers": "latest",
      "@theia/messages": "latest",
      "@theia/navigator": "latest",
      "@theia/preferences": "latest",
      "@theia/plugin-ext-vscode": "latest",
      "@theia/terminal": "latest",
      "@theia/callhierarchy": "latest",
      "@theia/file-search": "latest",
      "@theia/git": "latest",
      "@theia/mini-browser": "latest",
      "@theia/outline-view": "latest",
      "@theia/preview": "latest",
      "@theia/search-in-workspace": "latest",
      "@theia/console": "latest",
      "@theia/core": "latest",
      "@theia/cpp-debug": "latest",
      "@theia/debug": "latest",
      "@theia/editor": "latest",
      "@theia/filesystem": "latest",
      "@theia/keymaps": "latest",
      "@theia/metrics": "latest",
      "@theia/monaco": "latest",
      "@theia/output": "latest",
      "@theia/plugin": "latest",
      "@theia/plugin-ext": "latest",
      "@theia/process": "latest",
      "@theia/scm": "latest",
      "@theia/task": "latest",
      "@theia/userstorage": "latest",
      "@theia/variable-resolver": "latest",
      "@theia/vsx-registry": "latest",
      "@theia/workspace": "latest"
  },
  "devDependencies": {
      "@theia/cli": "latest"
  },
  "theiaPluginsDir": "plugins",
  "theiaPlugins": {
      "vscode-builtin-css": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/css-1.39.1-prel.vsix",
      "vscode-builtin-html": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/html-1.39.1-prel.vsix",
      "vscode-builtin-javascript": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/javascript-1.39.1-prel.vsix",
      "vscode-builtin-json": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/json-1.39.1-prel.vsix",
      "vscode-builtin-npm": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/npm-1.39.1-prel.vsix",
      "vscode-builtin-scss": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/scss-1.39.1-prel.vsix",
      "vscode-builtin-typescript": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/typescript-1.39.1-prel.vsix",
      "vscode-builtin-typescript-language-features": "https://github.com/theia-ide/vscode-builtin-extensions/releases/download/v1.39.1-prel/typescript-language-features-1.39.1-prel.vsix",
      "vscode-builtin-node-debug": "https://github.com/theia-ide/vscode-node-debug/releases/download/v1.35.3/node-debug-1.35.3.vsix",
      "vscode-builtin-node-debug2": "https://github.com/theia-ide/vscode-node-debug2/releases/download/v1.33.0/node-debug2-1.33.0.vsix"
  }
}

And this is the result when I select function and click Call Hierarchy on View menu (I’ve already tried with shortcut key)

While when I try with the “same” code on Theia IDE on Gitpod, it’s work.

Any idea how to get this working or my package.json has any mistake?

Regards,
PK

@PK thank you for the discussion, I do not see anything in your package.json that looks incorrect on first glance. Do you mind trying the following docker image example to see if you have the same problem:

You may also pull it from dockerhub:

@vince-fugnitto Thanks for your reply,
I have tried with the docker image example and unfortunately the call hierarchy still doesn’t work, so does theiaide/theia image from dockerhub.

@PK I had a little bit of time this morning to test as well, and noticed the same thing as you (when testing with typescript files):

  • eclipse theia sources: call-hierarchy is available in both the browser and electron example applications
  • gitpod: call-hierarchy is available when starting theia from gitpod
  • docker: call-hierarchy is not available from a docker image

I’ll open an issue to track the bug, and hopefully see as to why it fails in a docker image.
Thank you for reporting the problem!

@vince-fugnitto With pleasure and thank you for solving my doubts. :grinning: