What is required to enable the Developer Tools when running Theia in Electron?

I’m trying to get a minimal template of theia put together for experimenting. But I’m running into some troubles and need the console/debugger and don’t know what I need to add to get that to show up.

I can open it when using the full theia-blueprint repo, but in my code where I’m trying to build things up from scratch with minimal dependencies it just doesn’t react to Ctrl-Alt-i or selecting Help -> Toggle Developer Tools.

image

All of the documentation I can find seems to imply it should just work. I’ve tried adding all the dependencies and extensions from theia-blueprint, but I’m still not able to get the Developer Tools pane to pop up.

I appreciate any tips on what might be required.

@azdle thank you for the discussion, as far as I am aware they should be there by default from electron unless specifically removed through options. Do you mind sharing what you do in fact see, and possibly the package.json you are using to see if I can reproduce?

1 Like

Hi @vince-fugnitto, thanks for the quick reply.

This is my current minimal ish package.json. When I click that menu item or Ctrl-Alt-I I see nothing at all happen, both in the electron window and in the CLI where I ran yarn theia start.

{
  "private": true,
  "main": "src-gen/frontend/electron-main.js",
  "theia": {
    "target": "electron",
    "backend": {
      "config": {
        "startupTimeout": -1
      }
    },
    "frontend": {
      "config": {
        "applicationName": "Theia Thing"
      }
    }
  },
  "dependencies": {
    "@theia/callhierarchy": "1.17.2",
    "@theia/electron": "1.17.2",
    "@theia/debug": "1.17.2",
    "@theia/markers": "1.17.2",
    "@theia/messages": "1.17.2",
    "@theia/navigator": "1.17.2",
    "@theia/outline-view": "1.17.2",
    "@theia/preferences": "1.17.2",
    "@theia/preview": "1.17.2"
  },
  "devDependencies": {
    "@theia/cli": "1.17.2",
    "electron-builder": "~22.3.2"
  },
  "scripts": {
    "prepare": "yarn run clean && yarn build && yarn run download:plugins",
    "clean": "theia clean",
    "build": "theia build",
    "watch": "theia build --watch --mode development",
    "start": "theia start --plugins=local-dir:plugins",
    "download:plugins": "theia download:plugins",
    "package": "electron-builder",
    "package:preview": "electron-builder --dir"
  },
  "theiaPlugins": {},
  "theiaPluginsDir": "plugins",
  "theiaPluginsExcludeIds": []
}

I’m pointing at old versions of theia stuff because I’m going to be playing around with https://github.com/eclipse-cdt-cloud/theia-trace-extension and AFACT that’s what the only published version of that is compatible with. Although, I’m thinking that isn’t the problem because the AppImage example from that extension uses updated deps and has the same issue.

@azdle no problem, when I verified I could see that the menu item is present and works:

I did make sure to have a clean state however, I executed the command reset workbench layout in the application just to be safe.

Steps:

  • yarn
  • yarn theia rebuild:electron
  • yarn theia start
  • F1 > Reset Workbench Layout