Why and how can i fix this if Ive already got the latest node installed?

[1/6] Validating package.json…
error @theia/monorepo@0.0.0: The engine “node” is incompatible with this module. Expected version “>=10.11.0 <12”. Got “12.16.3”
error Found incompatible module.

[original thread by Jamie]

Hello @fivvr
you have to downgrade you node version. Theia cannot be launched on node 12

Please upvote here for Node.js 12 support: https://github.com/eclipse-theia/theia/issues/7349


Ok thank you @artem-z


Given the downgrade of node, I myself found it difficult doing this on Windows, though, there are shortcuts and ways installing the pre-reqs. However, I find that bending the versions for this isnt worth it and would be worth the wait when this does update to the latest node version. Less hassle and headachs.


I am sure others have had success, but thats probably around only 40% of the theia community. My math maybe wrong but either way, i am not wrong. I will just wait for a more updated framework


thanks for you two for helping

@fivvr we use nvm to easily change node versions on the system.
If you are using Windows then I’d suggest trying nvm-windows, it will allow you to install and use different node versions and specify which version to use.


i will try that and the project again after im done with this android project, thanks for your feedback

@fivvr please look at dev docs for windows: https://github.com/eclipse-theia/theia/blob/master/doc/Developing.md#building-on-windows