Yarn start the theia browser-app broken with node error [ERR_INVALID_SYNC_FORK_INPUT]

Hi,friends:
I am a new learner to the theia from China. Recently, i found an error while following the steps by the guide Authoring Extensions .

  1. OS : win11 professional
    2.node v12.22.0
  2. python 3.8.8
    I do as the steps at the end,after cd browser-app and yarn start ,it run without any error .But after I pointed my browser to [http://localhost:3000],it showed an node error

Blockquote ERROR TypeError [ERR_INVALID_SYNC_FORK_INPUT]: Asynchronous forks do not support Buffer, TypedArray, DataView or string input: ‘overlapped’

Blockquote
and the browser page came to a empty page with a loading icon in the center.
Tips: I have tried to chang other node version but useless.

Anyone have met this ? Could u give me some suggestion on solving this error ?
3q all.

@passion123 thank you for the discussion, please confirm that you satisfied all prerequisites, it looks like you are using an unsupported Node version (although I can’t tell which theia version you are using).

Also, please take a look at the frontend dev console if you experience problems where you’re stuck with the loading screen and so on, it should highlight errors that need to be addressed.

thx for your reply. i have tried another higher node version by prerequisites, but it shows defferent errors with different versions. Seems the v12 is the best to me…
And i checked the console,no error showed.

BTW, if OK, could u share me a complete extension preject example like the ‘hello word’ ?

and i will change the version to satisfied the prerequisites , and keep in touch and try to create the extension example by the gudie

@passion123 you can follow the authoring extensions guide which will point you to our yeoman generator where you can select the “hello world” example.

I did it and do it as the guide ,but seems all chinese developers are use node v10 or even v8, do u have any good idea on the environment on OS WIN11 ?Or just follow the prerequisites but it meets many errors in China


this is the node 16.17.0 and do as the steps
Is it OK ?

@passion123 it seems fine, you’ll need to make sure the build completes rather than interrupt it.

It stoped and broken self without any action from me. suffering :pensive:

seems the node version 16.17.0 is not suitable.when I used the version v16.15.1 ,it worked fine.Amazing!!!
Thx for ur attention :star_struck:

1 Like